Oracle issued security patches for recently discovered Spectre and Meltdown issues

Last week Oracle started releasing software and microcode updates for products affected by the recently disclosed variants of the Spectre and Meltdown flaws.

In May, tech giants Intel, AMD, ARM, IBM, Microsoft and other tech firms teamed to disclose two new variants of both Meltdown and Spectre issues.

The so-called Variant 4 (CVE-2018-3639) relies on a Speculative Store Bypass (SSB), while the Variant 3a (CVE-2018-3640) is a Rogue System Register.

Both Variant 4 and Variant 3a could be exploited by a local attacker for this reason they have been rated “medium severity”

According to Oracle’s security advisory, Variant 4 affects Oracle Linux versions 6 and 7, and Oracle VM 3.4,

“Systems with microprocessors utilizing speculative execution and speculative execution of memory reads before the addresses of all prior memory writes are known may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis, aka Speculative Store Bypass (SSB), Variant 4.” reads the security advisory published by Oracle.

Oracle Spectre fix

Oracle has released software updates for the Oracle Linux distribution and Oracle VM virtualization products, along with the microcode updates provided by Intel.

“Two new processor vulnerabilities were publicly disclosed on  May 21, 2018.  They are vulnerabilities CVE-2018-3640 ( “Spectre v3a” or “Rogue System Register Read”) and CVE-2018-3639 (“Spectre v4” or “Speculative Store Buffer Bypass”).  Both vulnerabilities have received a CVSS Base Score of 4.3.

Successful exploitation of vulnerability CVE-2018-3639 requires local access to the targeted system.  Mitigating this vulnerability on affected systems will require both software and microcode updates.” states Oracle in a blog post

“Oracle will continue to release new microcode updates and firmware patches as production microcode becomes available from Intel,” 

Oracle promptly addressed the initial Meltdown and Spectre vulnerabilities in January 2018 Critical Patch Update just after their disclosure.

Since January,  other side-channel attacks have been discovered, including BranchScope, SgxPectre, and the attacks against the System Management Mode (SMM) memory.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *